Applications by NP-Associates

Supports Final Cut Pro X version 10.1 through 10.3 libraries and Sierra. Supports Final Cut Pro X versions back to 10.0.4. Ever had your FCP X folders corrupted so you can't launch it? Ever gone down an editing path you didn't like and find you can'