Applications by Movist

************************** IMPORTANT ************************************* • Movist 1.3.6 or later does not support QuickTime decoder any more. FFmpeg decoder only. It’s caused by new policy of Mac App Store and QuickTime 7 should be remov