Applications by Authy-Inc

** Authy Bluetooth requires Bluetooth 4.0 for iphone. Please check that the LMP version on About this Mac ---> More Info ---> System Report --> Bluetooth is 0x6 if you are pairing to an iPhone ** Authy Bluetooth brings you all the benefits of Two-Fa